aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 88480853..d701981b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -435,6 +435,15 @@ AC_MSG_CHECKING([for Tornado])
if $PYTHON -c 'import tornado' 2>/dev/null; then have_tornado=yes; else have_tornado=no; fi
AC_MSG_RESULT([$have_tornado])
+if test $have_tornado = yes
+then
+ AC_MSG_CHECKING([for Tornado 4.2 or higher])
+ have_acceptable_tornado=`$PYTHON -c "import tornado; print 'no' if tornado.version_info < (4, 2) else 'yes'"`
+ AC_MSG_RESULT([$have_acceptable_tornado])
+else
+ have_acceptable_tornado=no
+fi
+
AC_MSG_CHECKING([for Django])
if $PYTHON -c 'import django' 2>/dev/null; then have_django=yes; else have_django=no; fi
AC_MSG_RESULT([$have_django])
@@ -513,10 +522,10 @@ then
AC_MSG_WARN([The RPKI tools require the Python argparse module.])
fi
-if test $have_tornado = no
+if test $have_acceptable_tornado = no
then
runtime_ok=no
- AC_MSG_WARN([The RPKI tools require the Python Tornado package.])
+ AC_MSG_WARN([The RPKI tools require Tornado 4.2 or higher.])
fi
if test $build_ca_tools = yes