aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2b14aef6..f584d24a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,15 +1,21 @@
# -*- Autoconf -*-
# $Id$
-AC_PREREQ(2.61)
-AC_INIT(rpkitools, 1.0,)
+AC_PREREQ([2.61])
+AC_INIT([rpkitools], [1.0])
+
+# AC_REVISION is a great idea in theory, but the revision will always
+# be wrong unless we do two checkins, so skip it for now. Someday.
+
+dnl AC_REVISION([$Revision$])
+
AC_CONFIG_SRCDIR([rcynic/rcynic.c])
AC_CONFIG_AUX_DIR([buildtools])
+AC_CANONICAL_HOST
+
AC_PROG_CC
AC_PROG_INSTALL
-AC_CANONICAL_HOST
-
AC_CHECK_SIZEOF([long])
# We'd like to build rcynic as a static binary if we can, because that