aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 9 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index f85fb909..a41ebeda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,7 +324,7 @@ RCYNIC_DIR='${DESTDIR}'"${rcynic_base_dir}"
# mostly matters on FreeBSD, where most things involving Apache encode
# the Apache version number into their filenames.
#
-# If we can't figure out the version number, we assume 2.2 and hope
+# If we can't figure out the version number, we assume 2.4 and hope
# for the best; at some point we may need to do better than this.
#
# apachectl sometimes whines about ulimits, so we discard its stderr.
@@ -347,8 +347,8 @@ fi
if test "X$APACHE_VERSION" = "X"
then
- APACHE_VERSION="22"
- msg='not found, defaulting to 2.2'
+ APACHE_VERSION="24"
+ msg='not found, defaulting to 2.4'
else
msg=`echo $APACHE_VERSION | sed 's=.=&.='`
fi
@@ -518,8 +518,8 @@ then
AC_MSG_ERROR([I can't find a Python binary at all, this isn't going to work. Perhaps you need to set PATH?])
fi
-AC_MSG_CHECKING([for Python version 2.6 or higher])
-have_acceptable_python=`$PYTHON -c 'import sys; print "yes" if sys.version_info[[0]] == 2 and sys.version_info[[1]] >= 6 else "no"'`
+AC_MSG_CHECKING([for Python version 2.7 or higher])
+have_acceptable_python=`$PYTHON -c 'import sys; print "yes" if sys.version_info[[0]] == 2 and sys.version_info[[1]] >= 7 else "no"'`
AC_MSG_RESULT([$have_acceptable_python])
AC_MSG_CHECKING([distutils to find out where Python.h should be])
@@ -542,8 +542,8 @@ AC_MSG_RESULT([$have_django])
if test $have_django = yes
then
- AC_MSG_CHECKING([for Django 1.3.7 or higher])
- have_acceptable_django=`$PYTHON -c "import django; print 'no' if django.VERSION < (1, 3, 7) else 'yes'"`
+ AC_MSG_CHECKING([for Django 1.8 or higher])
+ have_acceptable_django=`$PYTHON -c "import django; print 'no' if django.VERSION < (1, 8) else 'yes'"`
AC_MSG_RESULT([$have_acceptable_django])
else
have_acceptable_django=no
@@ -557,19 +557,6 @@ AC_MSG_CHECKING([for vobject])
if $PYTHON -c 'import vobject' 2>/dev/null; then have_vobject=yes; else have_vobject=no; fi
AC_MSG_RESULT([$have_vobject])
-AC_MSG_CHECKING([for Django South])
-if $PYTHON -c 'import south' 2>/dev/null; then have_django_south=yes; else have_django_south=no; fi
-AC_MSG_RESULT([$have_django_south])
-
-if test $have_django_south = yes
-then
- AC_MSG_CHECKING([for Django South 0.7.5 or later])
- have_acceptable_django_south=`$PYTHON -c "import south; print 'no' if map(int,south.__version__.split('.')) < [[0, 7, 5]] else 'yes'"`
- AC_MSG_RESULT([$have_acceptable_django_south])
-else
- have_acceptable_django_south=no
-fi
-
AC_MSG_CHECKING([for argparse])
if $PYTHON -c 'import argparse' 2>/dev/null; then have_argparse=yes; else have_argparse=no; fi
AC_MSG_RESULT([$have_argparse])
@@ -587,7 +574,7 @@ runtime_ok=yes
if test $have_acceptable_python = no
then
runtime_ok=no
- AC_MSG_WARN([The RPKI code requires Python version 2.x, for x = 6 or higher.])
+ AC_MSG_WARN([The RPKI code requires Python version 2.x, for x = 7 or higher.])
fi
if test $build_rp_tools = yes
@@ -619,18 +606,13 @@ then
if test $have_acceptable_django = no
then
runtime_ok=no
- AC_MSG_WARN([The RPKI CA tools require Django 1.3.7 or higher.])
+ AC_MSG_WARN([The RPKI CA tools require Django 1.8 or higher.])
fi
if test $have_vobject = no
then
runtime_ok=no
AC_MSG_WARN([The RPKI CA GUI requires the Python vobject module.])
fi
- if test $have_acceptable_django_south = no
- then
- runtime_ok=no
- AC_MSG_WARN([The RPKI CA tools require Django South 0.7.5 or higher.])
- fi
if test $have_argparse = no
then
runtime_ok=no