aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5de10657..80171c37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -456,6 +456,14 @@ then
# There is no standard name for this tool, so check for it.
AC_PATH_PROGS(DJANGO_ADMIN, [django-admin django-admin.py])
+ AC_MSG_CHECKING([for the vobject module])
+ if $PYTHON -c 'import vobject' 2>/dev/null
+ then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_ERROR([The Python vobject module is not installed. On Linux systems the package is typically called python-vobject, and on FreeBSD systems it is py27-vobject])
+ fi
+
AC_CONFIG_FILES([rpkid/Makefile rpkid/tests/Makefile rpkid/portal-gui/Makefile])
fi