aboutsummaryrefslogtreecommitdiff
path: root/rpkid/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'rpkid/setup.py')
-rw-r--r--rpkid/setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/rpkid/setup.py b/rpkid/setup.py
index 2e2a3b87..9f5082ef 100644
--- a/rpkid/setup.py
+++ b/rpkid/setup.py
@@ -23,6 +23,8 @@ import os
ac_cflags = os.getenv("AC_CFLAGS", "").split()
ac_ldflags = os.getenv("AC_LDFLAGS", "").split()
ac_libs = os.getenv("AC_LIBS", "").split()
+ac_sbindir = os.getenv("AC_SBINDIR", "").strip()
+ac_scripts = os.getenv("AC_SCRIPTS", "").split()
# Non-standard extension build specification: we need to force
# whatever build options our top-level ./configure selected, and we
@@ -41,6 +43,5 @@ setup(name = "rpkitoolkit",
license = "BSD",
url = "http://www.rpki.net/",
packages = ["rpki", "rpki.POW"],
- ext_modules = [pow])
-
-# Probably add other stuff here: scripts, data files, and so forth.
+ ext_modules = [pow],
+ data_files = [(ac_sbindir, ac_scripts)])