aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2019-08-11 09:16:00 -0400
committerRob Austein <sra@hactrn.net>2019-08-11 09:16:00 -0400
commit20889185ee8b909eaebea8f9a19611b235d564e4 (patch)
tree4395b0dfa75997486532025ac2660272e892d49a /setup.py
parentad131ab1eaf568e345f4c97fb2bcfef85be1924a (diff)
Packaging (setuptools and Debian)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..6ee211e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+from setuptools import setup, find_packages
+
+setup(
+ name = "zc",
+ version = "1.0",
+ packages = find_packages(),
+ scripts = ["zc", "git-remote-only"],
+ install_requires = ["dnspython", "GitPython"],
+
+ author = "Rob Austein",
+ author_email = "sra@hactrn.net",
+
+ url = "https://git.hactrn.net/sra/zc",
+ description = "A DNS zone compiler",
+ #long_description = open("README.md").read(),
+ #long_description_content_type = "text/markdown",
+
+ classifiers = [
+ "License :: OSI Approved :: ISC License"
+ ],
+)