aboutsummaryrefslogtreecommitdiff
path: root/buildtools/hack-debian-changelog.py
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2013-02-18 07:17:57 +0000
committerRob Austein <sra@hactrn.net>2013-02-18 07:17:57 +0000
commit468123b8c7ccb6c22fb27e051195623444ed031f (patch)
tree582db6b04763c9a29d83bdba44aaa1cd616fa22a /buildtools/hack-debian-changelog.py
parent9016fc3c7ca5ba922f039c1b67fcf70f7384155a (diff)
Install generated debian/changelog, now that we generate ones that debuild accepts.
svn path=/branches/tk377/; revision=5041
Diffstat (limited to 'buildtools/hack-debian-changelog.py')
-rw-r--r--buildtools/hack-debian-changelog.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/buildtools/hack-debian-changelog.py b/buildtools/hack-debian-changelog.py
index d46ea1d1..01d66fd3 100644
--- a/buildtools/hack-debian-changelog.py
+++ b/buildtools/hack-debian-changelog.py
@@ -29,6 +29,7 @@ import textwrap
import time
import calendar
import errno
+import os
try:
from lxml.etree import XML
@@ -103,5 +104,7 @@ if changed:
with open(fn + ".new", "w") as f:
print "Writing", f.name
changelog.write_to_open_file(f)
+ print "Renaming %s.new to %s" % (fn, fn)
+ os.rename(fn + ".new", fn)
else:
print "No changes"