aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2013-02-01 03:17:34 +0000
committerRob Austein <sra@hactrn.net>2013-02-01 03:17:34 +0000
commit1750b16a9ab7b208de25a1deafbd610dfd38e7f5 (patch)
treefb67737cc0647b2f52f1cc30cb09ef594a5f99cf /configure.ac
parent9f9f731c1318c27a1026408edee93c72d3c5a52a (diff)
Add rcynic-cron.
svn path=/branches/tk377/; revision=4998
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 23 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 050fb07a..37d280e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,13 +118,18 @@ then
fi
unset old_LDFLAGS
+AC_PROG_GREP
+AC_PATH_PROG([PYTHON], [python])
AC_PATH_PROG([XSLTPROC], [xsltproc])
AC_PATH_PROG([AWK], [awk])
AC_PATH_PROG([SORT], [sort])
AC_PATH_PROG([RRDTOOL], [rrdtool])
-AC_PROG_GREP
AC_PATH_PROG([TRANG], [trang], [\${abs_top_srcdir}/buildtools/trang-not-found])
AC_PATH_PROG([RSYNC], [rsync])
+AC_PATH_PROG([SU], [su])
+AC_PATH_PROG([SUDO], [sudo])
+AC_PATH_PROG([CHROOT], [chroot])
+AC_PATH_PROG([CHROOTUID], [chrootuid])
# Figure out whether we need to build our own OpenSSL library or can
# use the system libraries. We're looking for two recent features:
@@ -336,13 +341,28 @@ esac
AC_SUBST_FILE(RCYNIC_MAKE_RULES)
+# Where to put HTML files is similarly platform dependent, we have to know.
+# rcynic-cron will skip generating HTML files if it has no place to put them.
+
+case $host_os in
+ freebsd*)
+ RCYNIC_HTML_DIR='/usr/local/www/data/rcynic'
+ ;;
+ linux*)
+ RCYNIC_HTML_DIR='/var/www/rcynic'
+ ;;
+ *)
+ RCYNIC_HTML_DIR=''
+ ;;
+esac
+
+AC_SUBST(RCYNIC_HTML_DIR)
+
# Now a bunch of checks to figure out what we can do with Python. If
# we don't have Python at all, none of the rest of this matters. If
# we do have Python, we need to check for required packages and
# versions.
-AC_PATH_PROG([PYTHON], [python])
-
have_python=no
have_acceptable_python=no
have_python_h=no