aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2011-01-09 22:01:50 +0000
committerRob Austein <sra@hactrn.net>2011-01-09 22:01:50 +0000
commit1e43b890514e8de67f95917f9279b4641adebc06 (patch)
treee08d400858825e089533c3b9841c9c792fd54c4f /configure.ac
parentf05001f84d966a0b0c80b9d5212c2f3ac11d1660 (diff)
Have to build OpenSSL shared libraries even though we don't need them,
because we do need position independent code to build _POW.so. svn path=/configure; revision=3603
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4778bbf4..bdc7c564 100644
--- a/configure.ac
+++ b/configure.ac
@@ -269,18 +269,15 @@ if test $build_pywrap = yes
then
AC_CONFIG_FILES([pywrap/Makefile])
OPENSSL_SHARED_LIBRARY_DIR='${libdir}/rpki'
- OPENSSL_SHARED_LIBRARIES='enable-shared'
PYWRAP='${libexecdir}/pywrap'
PYWRAP_CMD='LD_LIBRARY_PATH="${abs_top_builddir}/openssl/openssl" ${abs_top_builddir}/pywrap/pywrap'
else
OPENSSL_SHARED_LIBRARY_DIR=''
- OPENSSL_SHARED_LIBRARIES='disable-shared'
PYWRAP="$PYTHON"
PYWRAP_CMD="$PYTHON"
fi
AC_SUBST(PYWRAP)
AC_SUBST(PYWRAP_CMD)
-AC_SUBST(OPENSSL_SHARED_LIBRARIES)
AC_SUBST(OPENSSL_SHARED_LIBRARY_DIR)
if test $build_python = yes