aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2011-03-04 13:37:18 +0000
committerRob Austein <sra@hactrn.net>2011-03-04 13:37:18 +0000
commit1f1468d9c6eb312a777f81ace5095566368bbc7c (patch)
tree771791d6aa69bd4345d52dd8f24fb2e9ba3e06ea /configure.ac
parent1ef9bcc07238c34b3031449d3e69dbb03c79bece (diff)
Add --disable-openssl-asm to cope with 64-bit Linux linkage mess
svn path=/configure.ac; revision=3714
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 24 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ccbaaf01..b1112578 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,6 +139,7 @@ fi
# something that just won't work, we say so and fail.
AC_ARG_ENABLE([system_openssl], [AS_HELP_STRING([--disable-system-openssl], [Don't build against system copy of OpenSSL])], [], [enable_system_openssl=auto])
+AC_ARG_ENABLE([openssl_asm], [AS_HELP_STRING([--disable-openssl-asm], [Don't let OpenSSL build assembler code])], [], [enable_openssl_asm=auto])
AC_ARG_ENABLE([python], [AS_HELP_STRING([--disable-python], [Don't build any of the Python-based tools])], [], [enable_python=auto])
AC_ARG_ENABLE([pywrap], [AS_HELP_STRING([--enable-pywrap], [Build pywrap])], [], [enable_pywrap=auto])
AC_ARG_ENABLE([django], [AS_HELP_STRING([--disable-django], [Don't build Django GUI])], [], [enable_django=auto])
@@ -162,6 +163,21 @@ case $enable_system_openssl in
*) AC_MSG_ERROR([Unrecognized value for --enable-system-openssl: $enable_system_openssl]);;
esac
+case $enable_openssl_asm in
+ yes|no) build_openssl_asm=$enable_openssl_asm
+ ;;
+ auto) case $host in
+ x86_64-*-linux*)
+ build_openssl_asm=no
+ ;;
+ *)
+ build_openssl_asm=yes
+ ;;
+ esac
+ ;;
+ *) AC_MSG_ERROR([Unrecognized value for --enable-openssl-asm: $enable_openssl_asm]);;
+esac
+
case $enable_python in
yes) build_python=yes
if test $have_python = no
@@ -262,7 +278,6 @@ then
AC_CONFIG_FILES([openssl/Makefile openssl/tests/Makefile])
AC_MSG_CHECKING([what configuration target to use when building OpenSSL])
- OPENSSL_CONFIG_COMMAND='./config'
case $host in
i*86-apple-darwin*)
if test "$ac_cv_sizeof_long" = 8
@@ -270,6 +285,14 @@ then
OPENSSL_CONFIG_COMMAND='./Configure darwin64-x86_64-cc'
fi
;;
+ *)
+ if test $build_openssl_asm = yes
+ then
+ OPENSSL_CONFIG_COMMAND='./config'
+ else
+ OPENSSL_CONFIG_COMMAND='./config no-asm'
+ fi
+ ;;
esac
AC_SUBST(OPENSSL_CONFIG_COMMAND)
AC_MSG_RESULT([$OPENSSL_CONFIG_COMMAND])