aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2011-01-28 16:15:09 +0000
committerRob Austein <sra@hactrn.net>2011-01-28 16:15:09 +0000
commit56f544af4013fab6d6b279289d61a29ae1e9f6f6 (patch)
treea90da686a7cc8c6d9a5fc4954fc4d23753cb7b51 /configure.ac
parent32c247ef4a2de3b4fd53dba7b3515fca98c946b7 (diff)
Autoconf installation script for rcynic on Linux, because at least one
required program (awk) lives in different places in different distros. rcynic installation parameters probably ought to be configurable via autoconf too, but don't worry about that for now. svn path=/configure; revision=3671
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 8 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 01837c16..d27a3814 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,11 +62,6 @@ AC_PATH_PROG([XSLTPROC], [xsltproc])
AC_PATH_PROG([AWK], [awk])
AC_PROG_GREP
-if test "x$GREP" = x
-then
- AC_MSG_ERROR([Tests requires grep, sorry])
-fi
-
if test "x$XSLTPROC" != "x" && test "x$AWK" != "x"
then
AC_CONFIG_FILES([rcynic/show.sh],
@@ -246,15 +241,15 @@ AC_CONFIG_FILES([Makefile
utils/print_roa/Makefile
utils/uri/Makefile])
+case $host_os in
+linux*)
+ AC_CONFIG_FILES([rcynic/installation-scripts/linux/install.sh])
+ ;;
+esac
+
# OpenSSL has its own build system that bears no relationship to
-# anything but itself. On at least one platform, OpenSSL's opinion on
-# the right thing to do is so completely at odds with everything else
-# that the resulting libraries require special compilation options for
-# any program that wants to use them. Feh.
-#
-# The -rpath insanity will need to change once we install this stuff.
-#
-# Don't bother with any of this unless we're building OpenSSL.
+# anything but itself, and our use of it is a bit weird, so this is a
+# BFMI (Brute Force and Massive Ignorance) job.
if test $build_openssl = yes
then