aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2010-12-29 23:57:20 +0000
committerRob Austein <sra@hactrn.net>2010-12-29 23:57:20 +0000
commit5f40b12f74f33263a1f2cbfd73fa5038d2b26d4b (patch)
tree1cd48f9de30ebae801aef5cd10006921e2caae67 /configure.ac
parent0ab93d5e0fe55b22704a264ff572af598b3e632e (diff)
Cleanup
svn path=/configure; revision=3585
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 562f0906..699b5d5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -249,7 +249,9 @@ AC_SUBST(RPKITOOLS_TOP_BUILDDIR)
# any program that wants to use them. We also have to sort out whether
# the linker is going to require shared libraries. Feh.
#
-# Don't bother with this unless we're building OpenSSL.
+# The -rpath insanity will need to change once we install this stuff.
+#
+# Don't bother with any of this unless we're building OpenSSL.
if test $build_openssl = yes
then
@@ -274,15 +276,11 @@ then
if test $need_openssl_shared = yes
then
OPENSSL_SHARED_LIBRARIES='enable-shared'
-
- # This -rpath insanity will need to change once we install this stuff
LDFLAGS="$LDFLAGS -Wl,-rpath,$RPKITOOLS_TOP_BUILDDIR/openssl/openssl"
-
else
OPENSSL_SHARED_LIBRARIES='disable-shared'
fi
AC_SUBST(OPENSSL_SHARED_LIBRARIES)
- AC_MSG_RESULT([$OPENSSL_SHARED_LIBRARIES])
fi
# Sort out which interpreter POW-using Python programs should use.