aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Elkins <melkins@tislabs.com>2013-03-07 18:47:07 +0000
committerMichael Elkins <melkins@tislabs.com>2013-03-07 18:47:07 +0000
commit697842ddc15e1d92e4dfc653038de309a1a20e8d (patch)
treef5395e6b296bb80aa4441fcebcf51aa24a3cb148 /configure.ac
parent353e21c13948820776376e724ade98b408603727 (diff)
use --enable-target-install framework to add install-linux to the install target for the web portal
svn path=/trunk/; revision=5120
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b98f4ca3..fd489467 100644
--- a/configure.ac
+++ b/configure.ac
@@ -376,6 +376,7 @@ AC_SUBST(RCYNIC_HTML_DIR)
RCYNIC_INSTALL_TARGETS='install-always'
RTR_ORIGIN_INSTALL_TARGETS='install-always'
+GUI_INSTALL_TARGETS='install-always'
if test $use_rcynic_jail = yes
then
@@ -386,10 +387,18 @@ if test $enable_target_installation = yes
then
RCYNIC_INSTALL_TARGETS="$RCYNIC_INSTALL_TARGETS install-postconf"
RTR_ORIGIN_INSTALL_TARGETS="$RTR_ORIGIN_INSTALL_TARGETS install-postconf"
+
+ case $host_os in
+ linux*)
+ GUI_INSTALL_TARGETS="$GUI_INSTALL_TARGETS install-linux"
+ ;;
+ esac
+
fi
AC_SUBST(RCYNIC_INSTALL_TARGETS)
AC_SUBST(RTR_ORIGIN_INSTALL_TARGETS)
+AC_SUBST(GUI_INSTALL_TARGETS)
# Now a bunch of checks to figure out what we can do with Python. If
# we don't have Python at all, none of the rest of this matters. If