aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2013-02-24 03:22:00 +0000
committerRob Austein <sra@hactrn.net>2013-02-24 03:22:00 +0000
commit7420e8df36b0156c73b19c45e2c25a389518fae1 (patch)
tree3d78451ed95b6ccb0354896453335dd2f53b7837 /configure.ac
parentf419595c47e338978c3263d22085e75d452f7283 (diff)
inetd/xinetd listener for rpki-rtr on source code installation, also needed for Ubuntu package.
svn path=/branches/tk377/; revision=5058
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 13 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 61b979ce..4398bbce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,23 +330,29 @@ AC_MSG_RESULT([$enable_target_installation])
# rcynic jail setup is complicated enough that it's simplest to have
# different rule sets for different platforms. Icky, but....
+# rpki-rtr isn't as complicated, but has similar issues, same hack.
case $host_os in
darwin*)
RCYNIC_MAKE_RULES='rcynic/rules.darwin.mk'
+ RTR_ORIGIN_MAKE_RULES='rtr-origin/rules.darwin.mk'
;;
freebsd*)
RCYNIC_MAKE_RULES='rcynic/rules.freebsd.mk'
+ RTR_ORIGIN_MAKE_RULES='rtr-origin/rules.freebsd.mk'
;;
linux*)
RCYNIC_MAKE_RULES='rcynic/rules.linux.mk'
+ RTR_ORIGIN_MAKE_RULES='rtr-origin/rules.linux.mk'
;;
*)
RCYNIC_MAKE_RULES='rcynic/rules.unknown.mk'
+ RTR_ORIGIN_MAKE_RULES='rtr-origin/rules.unknown.mk'
;;
esac
AC_SUBST_FILE(RCYNIC_MAKE_RULES)
+AC_SUBST_FILE(RTR_ORIGIN_MAKE_RULES)
# Where to put HTML files is similarly platform dependent, we have to know.
# rcynic-cron will skip generating HTML files if it has no place to put them.
@@ -369,6 +375,7 @@ AC_SUBST(RCYNIC_HTML_DIR)
# we're doing final target installation.
RCYNIC_INSTALL_TARGETS='install-always'
+RTR_ORIGIN_INSTALL_TARGETS='install-always'
if test $use_rcynic_jail = yes
then
@@ -378,9 +385,11 @@ fi
if test $enable_target_installation = yes
then
RCYNIC_INSTALL_TARGETS="$RCYNIC_INSTALL_TARGETS install-postconf"
+ RTR_ORIGIN_INSTALL_TARGETS="$RTR_ORIGIN_INSTALL_TARGETS install-postconf"
fi
AC_SUBST(RCYNIC_INSTALL_TARGETS)
+AC_SUBST(RTR_ORIGIN_INSTALL_TARGETS)
# Now a bunch of checks to figure out what we can do with Python. If
# we don't have Python at all, none of the rest of this matters. If
@@ -582,11 +591,10 @@ fi
# Figure out which parts of this package we have to build.
- TOP_LEVEL_SUBDIRS=""
-test $build_openssl = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS openssl"
- TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS h"
-test $build_rp_tools = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS h rcynic utils rtr-origin"
-test $build_ca_tools = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS rpkid"
+ TOP_LEVEL_SUBDIRS="h"
+test $build_openssl = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS openssl"
+test $build_rp_tools = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS rcynic utils rtr-origin"
+test $build_ca_tools = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS rpkid"
AC_SUBST(TOP_LEVEL_SUBDIRS)