aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2013-02-01 21:50:18 +0000
committerRob Austein <sra@hactrn.net>2013-02-01 21:50:18 +0000
commit7ec1ead3187873e775036606f51cb4135408ce09 (patch)
treec9cd2c216c4ccd6cf26c9c84f9f6b579f5e795b3 /configure.ac
parent27d85628a8ebe96c3adc2dbeac0e58160c727071 (diff)
Finally ready to start testing new rcynic install code.
svn path=/branches/tk377/; revision=5002
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2544f64a..7853d374 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,9 +288,11 @@ esac
AC_SUBST(RCYNIC_JAIL_DIRS)
AC_SUBST(RCYNIC_CONF_FILE)
AC_SUBST(RCYNIC_TA_DIR)
+AC_SUBST(RCYNIC_BIN_RCYNIC)
AC_SUBST(RCYNIC_CONF_RSYNC)
AC_SUBST(RCYNIC_CONF_DATA)
AC_SUBST(RCYNIC_CONF_TA_DIR)
+AC_SUBST(RCYNIC_CRON_USER)
AC_MSG_RESULT([$use_rcynic_jail])
@@ -360,6 +362,23 @@ esac
AC_SUBST(RCYNIC_HTML_DIR)
+# Sort out which things to install, depending on rcynic jail status and whether
+# we're doing final target installation.
+
+RCYNIC_INSTALL_TARGETS='install-always'
+
+if test $use_rcynic_jail = yes
+then
+ RCYNIC_INSTALL_TARGETS="$RCYNIC_INSTALL_TARGETS install-jailed"
+fi
+
+if test $enable_target_installation = yes
+then
+ RCYNIC_INSTALL_TARGETS="$RCYNIC_INSTALL_TARGETS install-postconf"
+fi
+
+AC_SUBST(RCYNIC_INSTALL_TARGETS)
+
# Now a bunch of checks to figure out what we can do with Python. If
# we don't have Python at all, none of the rest of this matters. If
# we do have Python, we need to check for required packages and