aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2011-01-20 13:41:20 +0000
committerRob Austein <sra@hactrn.net>2011-01-20 13:41:20 +0000
commit81fbac5c5165e53236b821e9238aafeebc4076fd (patch)
tree1f837a9eb445285621634651238f9dd417d6f96f /configure.ac
parent3debee4485f6668dcc3e74fac26163350edfdd22 (diff)
Fix all the broken RPATH stuff we said we'd fix "some day".
svn path=/configure; revision=3615
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 05a2c43f..ed576056 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,7 +242,7 @@ AC_CONFIG_FILES([Makefile
if test $build_openssl = yes
then
- AC_CONFIG_FILES([openssl/Makefile])
+ AC_CONFIG_FILES([openssl/Makefile openssl/tests/Makefile])
AC_MSG_CHECKING([what configuration target to use when building OpenSSL])
OPENSSL_CONFIG_COMMAND='./config'
@@ -268,17 +268,17 @@ fi
if test $build_pywrap = yes
then
AC_CONFIG_FILES([pywrap/Makefile])
- OPENSSL_SHARED_LIBRARY_DIR='${libdir}/rpki'
PYWRAP='${libexecdir}/pywrap'
PYWRAP_CMD='LD_LIBRARY_PATH="${abs_top_builddir}/openssl/openssl" ${abs_top_builddir}/pywrap/pywrap'
+ PYWRAP_LIBDIR='${libdir}/pywrap'
else
- OPENSSL_SHARED_LIBRARY_DIR=''
PYWRAP="$PYTHON"
PYWRAP_CMD="$PYTHON"
+ PYWRAP_LIBDIR=''
fi
AC_SUBST(PYWRAP)
AC_SUBST(PYWRAP_CMD)
-AC_SUBST(OPENSSL_SHARED_LIBRARY_DIR)
+AC_SUBST(PYWRAP_LIBDIR)
if test $build_python = yes
then