aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Elkins <melkins@tislabs.com>2013-03-06 17:28:54 +0000
committerMichael Elkins <melkins@tislabs.com>2013-03-06 17:28:54 +0000
commita7d2c771baca842f25cf1c09927ec05a56732537 (patch)
tree9b763fa425e79adfd300d2c70db0cdaa164e80bc /configure.ac
parentce8df807660789acaaa544570ff541ef35c856b0 (diff)
display error message if username was omitted when specifying --enable-wsgi-daemon-mode
svn path=/trunk/; revision=5113
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51f432d2..3a7ef243 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,6 +688,9 @@ then
if test "$enable_wsgi_daemon_mode" != no
then
+ if test "$enable_wsgi_daemon_mode" = yes; then
+ AC_MSG_ERROR([You must specify the user to run the wsgi process as with --enable-wsgi-daemon-mode=USER])
+ fi
save_IFS="$IFS"
IFS=':' read user group <<_EOF
$enable_wsgi_daemon_mode