aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2013-09-26 18:30:45 +0000
committerRob Austein <sra@hactrn.net>2013-09-26 18:30:45 +0000
commitb5611241747293298bafb9cef9558233ea9b9cda (patch)
tree2246d95e3584421fd326fcb066375fa0a9d87ee0 /configure.ac
parenta9ffe0ea529cba712568f12ea9bf9dba8b85708e (diff)
Silence apachectl whining about ulimits during autoconf.
svn path=/trunk/; revision=5525
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2b0b5e98..308ad54a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,6 +263,10 @@ RCYNIC_DIR='${DESTDIR}'"${rcynic_base_dir}"
#
# If we can't figure out the version number, we assume 2.2 and hope
# for the best; at some point we may need to do better than this.
+#
+# apachectl sometimes whines about ulimits, so we discard its stderr.
+# If you're reading this because this test is misbehaving, well,
+# try not discarding stderr.
AC_MSG_CHECKING([Apache version])
@@ -272,7 +276,7 @@ then
do
if test -x $apachectl
then
- APACHE_VERSION=`$apachectl -v | sed -n 's=^Server version: Apache/\([[0-9]]*\)\.\([[0-9]]*\)\..*$=\1\2=p'`
+ APACHE_VERSION=`$apachectl -v 2>/dev/null | sed -n 's=^Server version: Apache/\([[0-9]]*\)\.\([[0-9]]*\)\..*$=\1\2=p'`
break
fi
done