aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2013-03-08 04:32:55 +0000
committerRob Austein <sra@hactrn.net>2013-03-08 04:32:55 +0000
commitbdb0030d7a78ea608f3fa0591565275cf203147b (patch)
treef6cd73fe64af1f33282f30deb2501a38ae6bac09 /configure.ac
parent51e0b2a082e3abd88ff909f28e15ab963eabf622 (diff)
Whack OpenSSL configuration to pull its notion of the CPU from
autoconf rather than deducing this on its own, so that we can use pbuilder and pbuilder-dist to build both 32-bit and 64-bit packages on the same 64-bit Ubuntu machine. See #423. svn path=/trunk/; revision=5124
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 00731807..a61ad2ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,7 +11,14 @@ dnl AC_REVISION([$Revision$])
AC_CONFIG_SRCDIR([rcynic/rcynic.c])
AC_CONFIG_AUX_DIR([buildtools])
+
+# I'm not sure we should really be using the $host_* variables as we
+# are, some of the stuff we're doing with them looks more like
+# $target_* to me now, but on the theory that we should not fix things
+# that aren't broken, stick with $host_* for now.
+
AC_CANONICAL_HOST
+dnl AC_CANONICAL_TARGET
# Remember whether CFLAGS or LDFLAGS were set explictly. This has to
# come early in the script, before we mess it up testing things.
@@ -653,9 +660,9 @@ then
*)
if test $build_openssl_asm = yes
then
- OPENSSL_CONFIG_COMMAND='./config'
+ OPENSSL_CONFIG_COMMAND="MACHINE=$host_cpu ./config"
else
- OPENSSL_CONFIG_COMMAND='./config no-asm'
+ OPENSSL_CONFIG_COMMAND="MACHINE=$host_cpu ./config no-asm"
fi
;;
esac