aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2012-09-19 21:28:34 +0000
committerRob Austein <sra@hactrn.net>2012-09-19 21:28:34 +0000
commitc5ae5ad3053be9b246dec019a5a1c0e3f310a477 (patch)
tree01053007537c4005b6936b8f357879ec91faf579 /configure.ac
parente84b489d2676abe1e9f7ebc78a0f06a2141d1c58 (diff)
Move ASN.1 definitions for ROAs and Manifests to common header files
used by all the C programs. svn path=/branches/tk274/; revision=4725
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c3f927de..1aba6106 100644
--- a/configure.ac
+++ b/configure.ac
@@ -373,13 +373,14 @@ fi
TOP_LEVEL_SUBDIRS=""
test $build_openssl = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS openssl"
- TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS rcynic utils"
+ TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS h rcynic utils"
test $build_ca_tools = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS rpkid"
test $build_rpki_rtr = yes && TOP_LEVEL_SUBDIRS="$TOP_LEVEL_SUBDIRS rtr-origin"
AC_SUBST(TOP_LEVEL_SUBDIRS)
AC_CONFIG_FILES([Makefile
+ h/Makefile
rcynic/Makefile
rcynic/static-rsync/Makefile
utils/Makefile
@@ -471,4 +472,11 @@ then
AC_CONFIG_FILES([rtr-origin/Makefile])
fi
+# Now that we're finally done with all the conditional changes to
+# CFLAGS, add a search directive for our own header directory. If we
+# ever get to the point of having our own library directory, we'd add
+# it here too, but for the moment our shared C code is all in .h files.
+
+CFLAGS="$CFLAGS -I\${abs_top_srcdir}/h"
+
AC_OUTPUT