aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2012-05-23 00:54:35 +0000
committerRob Austein <sra@hactrn.net>2012-05-23 00:54:35 +0000
commitce78c5efb30ce726ea603529ecdd0499c07626da (patch)
treecbe5754d225ce30f7bad00148f58eb6f45986837 /configure.ac
parent4dddc12cfdaf35f5f3c852b48a3d38b7ee25aaed (diff)
Use autoconf to find rrdtool.
svn path=/trunk/; revision=4509
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cab2685e..5de10657 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,7 @@ unset old_LDFLAGS
AC_PATH_PROG([XSLTPROC], [xsltproc])
AC_PATH_PROG([AWK], [awk])
AC_PATH_PROG([SORT], [sort])
+AC_PATH_PROG([RRDTOOL], [rrdtool])
AC_PROG_GREP
if test "x$XSLTPROC" != "x" && test "x$AWK" != "x"
@@ -351,6 +352,11 @@ then
AC_MSG_WARN([xsltproc missing, so "make test" will not work properly.])
fi
+if test "x$RRDTOOL" = "x"
+then
+ AC_MSG_WARN([rrdtool missing, so rcynic-html won't be able to draw graphs.])
+fi
+
if test $ok = no
then
AC_MSG_ERROR([Please correct the problems above then re-run this configuration script.])