aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Elkins <melkins@tislabs.com>2013-02-28 17:15:00 +0000
committerMichael Elkins <melkins@tislabs.com>2013-02-28 17:15:00 +0000
commitcfa07eba076c7728c0de4ba5669a222742d04d70 (patch)
treea54389d42d5caa760e5c57b43a0e9f55bcb7be70 /configure.ac
parentfa8491add8e4a5895ea96f5f5cb1f01273185f0e (diff)
if the django-admin script is not found, configure should exit and inform the user so they can correct their $PATH
see #431 svn path=/trunk/; revision=5090
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 51f432d2..e87b25f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -684,7 +684,10 @@ then
AC_SUBST(DJANGO_DIR, [`$PYTHON -c 'import os,sys; print [[os.path.join(p, "django") for p in sys.path if os.path.exists(os.path.join(p, "django"))]][[0]]'`])
# There is no standard name for this tool, so check for it.
- AC_PATH_PROGS(DJANGO_ADMIN, [django-admin django-admin.py])
+ AC_PATH_PROGS(DJANGO_ADMIN, [django-admin django-admin.py], [no])
+ if test "$DJANGO_ADMIN" = no; then
+ AC_MSG_ERROR([unable to locate the django-admin script in your \$PATH])
+ fi
if test "$enable_wsgi_daemon_mode" != no
then