aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2010-12-29 01:38:53 +0000
committerRob Austein <sra@hactrn.net>2010-12-29 01:38:53 +0000
commite0f59781161f8faf2ca51265041852980ae66f85 (patch)
tree738d9909ae4646d8f104eb00943f7eb8f696c0a5 /configure.ac
parent6b34f4c5976637fbcd3652f499ece7daff24dadf (diff)
Start autoconf work for POW et al
svn path=/configure; revision=3581
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 28f41b9d..43cecdfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -239,7 +239,9 @@ then
AC_SUBST(OPENSSL_CONFIG_COMMAND)
AC_MSG_RESULT([$OPENSSL_CONFIG_COMMAND])
- LDFLAGS="$LDFLAGS -L$RPKITOOLS_TOP_BUILDDIR/openssl/openssl"
+ # This -rpath insanity will need to change once we install this stuff
+
+ LDFLAGS="$LDFLAGS -L$RPKITOOLS_TOP_BUILDDIR/openssl/openssl -Wl,-rpath,$RPKITOOLS_TOP_BUILDDIR/openssl/openssl"
CFLAGS="$CFLAGS -I$RPKITOOLS_TOP_BUILDDIR/openssl/openssl/include"
fi
@@ -247,6 +249,8 @@ fi
if test $build_pywrap = yes
then
+ AC_CONFIG_FILES([pywrap/Makefile])
+
# Eventually this should be the installation directory, but
# for now we're still running out of the build tree.
PYWRAP=$RPKITOOLS_TOP_BUILDDIR/pow/pywrap/pywrap
@@ -258,6 +262,8 @@ AC_SUBST(PYWRAP)
if test $build_python = yes
then
+ AC_CONFIG_FILES([pow/Makefile rpkid/Makefile rpkid/tests/Makefile])
+
# These are plain Python scripts, do not require pywrap
AC_CONFIG_FILES([rpkid/backup-sql:buildtools/python-header:rpkid/backup-sql.py], [chmod +x rpkid/backup-sql])
AC_CONFIG_FILES([rpkid/sql-setup:buildtools/python-header:rpkid/sql-setup.py], [chmod +x rpkid/sql-setup])