aboutsummaryrefslogtreecommitdiff
path: root/rpkid/setup.py
diff options
context:
space:
mode:
authorMichael Elkins <melkins@tislabs.com>2012-11-26 03:49:18 +0000
committerMichael Elkins <melkins@tislabs.com>2012-11-26 03:49:18 +0000
commit944d9b4a446c1401268d7ef8efb40b923177be95 (patch)
tree845333bd85b4826d780d3207202b43305901c873 /rpkid/setup.py
parent6b24f45e97061a7bafa9af1a7efd21311892bcc4 (diff)
rewrite ghostbuster_{create,edit} not to use generic views
make sure to set the .vcard field when saving a ghostbuster request display the list of covering ROAs from the rcynic cache in the route detail view rename route_roa_list to route_detail remove the delete button from the object_detail.html template since not all objects that use it can be deleted set STATIC_ROOT in settings.py so that collectstatic works svn path=/branches/tk329/; revision=4901
Diffstat (limited to 'rpkid/setup.py')
-rw-r--r--rpkid/setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/rpkid/setup.py b/rpkid/setup.py
index ee6f04ef..db7e0135 100644
--- a/rpkid/setup.py
+++ b/rpkid/setup.py
@@ -69,6 +69,10 @@ setup(name = "rpkitoolkit",
"rpki.gui", "rpki.gui.app", "rpki.gui.cacheview",
"rpki.gui.api", "rpki.gui.routeview" ],
ext_modules = [pow],
- package_data = {'rpki.gui.app': ['migrations/*.py', 'templates/*.html', 'templates/*/*.html', 'templatetags/*.py'],
- 'rpki.gui.cacheview': ['templates/*/*.html']},
+ package_data = {
+ 'rpki.gui.app': ['migrations/*.py', 'static/*/*',
+ 'templates/*.html', 'templates/*/*.html',
+ 'templatetags/*.py'],
+ 'rpki.gui.cacheview': ['templates/*/*.html']
+ },
data_files = data_files)