aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 32238b9a..1a00877c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,6 +203,11 @@ case $enable_django in
no) build_django=no
;;
auto) build_django=$have_django
+ if test "x$CONFDIR" = "x"
+ then
+ AC_MSG_WARN([Django installed but CONFUSER not set, not attempting to build the Django-based GUI])
+ build_django=no
+ fi
;;
*) AC_MSG_ERROR([Unrecognized value for --enable-django: $enable_django]);;
esac
@@ -301,21 +306,21 @@ fi
if test $build_django = yes
then
- if test -z "$CONFDIR"; then
+ if test "x$CONFDIR" = "x"; then
AC_MSG_ERROR([You must specify the root directory containing all resource handles to serve the via the portal-gui with the option CONFDIR=<PATH>])
#CONFDIR="\${abs_top_srcdir}/rpkid/tests/yamltest.dir"
fi
AC_SUBST(CONFDIR)
# the user that the apache process is running as
- if test -z "$WEBUSER"; then
- for u in apache www-data; do
- if `grep -q $u /etc/passwd`; then
+ if test "x$WEBUSER" = "x"; then
+ for u in apache www www-data; do
+ if $GREP $u /etc/passwd >/dev/null 2>&1; then
WEBUSER=$u
break
fi
done
- if test -z "$WEBUSER"; then
+ if test "x$WEBUSER" = "x"; then
AC_MSG_ERROR([Could not determine which user the apache process runs as. Please specify WEBUSER=<USERNAME>.])
fi
fi