aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2b0b5e98..308ad54a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,6 +263,10 @@ RCYNIC_DIR='${DESTDIR}'"${rcynic_base_dir}"
#
# If we can't figure out the version number, we assume 2.2 and hope
# for the best; at some point we may need to do better than this.
+#
+# apachectl sometimes whines about ulimits, so we discard its stderr.
+# If you're reading this because this test is misbehaving, well,
+# try not discarding stderr.
AC_MSG_CHECKING([Apache version])
@@ -272,7 +276,7 @@ then
do
if test -x $apachectl
then
- APACHE_VERSION=`$apachectl -v | sed -n 's=^Server version: Apache/\([[0-9]]*\)\.\([[0-9]]*\)\..*$=\1\2=p'`
+ APACHE_VERSION=`$apachectl -v 2>/dev/null | sed -n 's=^Server version: Apache/\([[0-9]]*\)\.\([[0-9]]*\)\..*$=\1\2=p'`
break
fi
done