aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cab2685e..5de10657 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,7 @@ unset old_LDFLAGS
AC_PATH_PROG([XSLTPROC], [xsltproc])
AC_PATH_PROG([AWK], [awk])
AC_PATH_PROG([SORT], [sort])
+AC_PATH_PROG([RRDTOOL], [rrdtool])
AC_PROG_GREP
if test "x$XSLTPROC" != "x" && test "x$AWK" != "x"
@@ -351,6 +352,11 @@ then
AC_MSG_WARN([xsltproc missing, so "make test" will not work properly.])
fi
+if test "x$RRDTOOL" = "x"
+then
+ AC_MSG_WARN([rrdtool missing, so rcynic-html won't be able to draw graphs.])
+fi
+
if test $ok = no
then
AC_MSG_ERROR([Please correct the problems above then re-run this configuration script.])