aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2021-11-14 20:21:23 -0500
committerRob Austein <sra@hactrn.net>2021-11-14 20:21:23 -0500
commit7d6eb4f759fcec4da6d014e10ab82430a8c13c05 (patch)
treea8262b71edd265244398fa067a2117b4d75d3e88 /debian
parent92cbded2a3207c55e03b117b1ccbc8d9a5f084ea (diff)
Convert to Python 3
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules2
2 files changed, 4 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index c8111db..a746e69 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: zc
Maintainer: Rob Austein <sra@hactrn.net>
Section: python
Priority: optional
-Build-Depends: dh-python, python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9)
+Build-Depends: dh-python, python3-setuptools (>= 0.6b3), python3-all (>= 2.6.6-3), debhelper (>= 9)
Standards-Version: 3.9.6
Homepage: https://git.hactrn.net/sra/zc
-Package: python-zc
+Package: python3-zc
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}, python-dnspython, python-git
+Depends: ${misc:Depends}, ${python3:Depends}, python3-dnspython, python3-git
Description: A DNS zone compiler
This is a small tool for generating DNS zones from relatively
simple text files, with some automation to handle complex or
diff --git a/debian/rules b/debian/rules
index 72c4fa7..3ec1a15 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,5 +2,5 @@
export PYBUILD_NAME=zc
%:
- dh $@ --with python2 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild