aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..6ee211e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+from setuptools import setup, find_packages
+
+setup(
+ name = "zc",
+ version = "1.0",
+ packages = find_packages(),
+ scripts = ["zc", "git-remote-only"],
+ install_requires = ["dnspython", "GitPython"],
+
+ author = "Rob Austein",
+ author_email = "sra@hactrn.net",
+
+ url = "https://git.hactrn.net/sra/zc",
+ description = "A DNS zone compiler",
+ #long_description = open("README.md").read(),
+ #long_description_content_type = "text/markdown",
+
+ classifiers = [
+ "License :: OSI Approved :: ISC License"
+ ],
+)